PHP

安装php的gd扩展缺少依赖报错

具体情况如下:
[root@79876938d0d3 src]# rpm -ivh php54w-gd-5.4.45-2.w6.x86_64.rpm

error: Failed dependencies:

    libfreetype.so.6()(64bit) is needed by php54w-gd-5.4.45-2.w6.x86_64

    libjpeg.so.62()(64bit) is needed by php54w-gd-5.4.45-2.w6.x86_64

    libjpeg.so.62(LIBJPEG_6.2)(64bit) is needed by php54w-gd-5.4.45-2.w6.x86_64

    libpng12.so.0()(64bit) is needed by php54w-gd-5.4.45-2.w6.x86_64

    libpng12.so.0(PNG12_0)(64bit) is needed by php54w-gd-5.4.45-2.w6.x86_64

    libt1.so.5()(64bit) is needed by php54w-gd-5.4.45-2.w6.x86_64

    libXpm.so.4()(64bit) is needed by php54w-gd-5.4.45-2.w6.x86_64
如何解决?
已邀请:

采菊篱下 - 无分享不快乐 助力技术开源分享 运维一枚

赞同来自: koyo

libfreetype.so.6解决:
yum -y install freetype

libjpeg.so.62()(64bit)解决:
yum -y install libjpeg


libpng12.so.0()解决:
yum -y install libpng

libt1.so.5()(64bit)解决:
yum -y install t1lib

libXpm.so.4()(64bit)解决:
yum -y install libXpm

 

要回复问题请先登录注册